Overview
This will be a configuration guide for configuring an MXnet network switch to work in tandem with the AC-MXNET-1G-DANTE-EV2 and AC-MXNET-1G-DANTE-DV2 devices.
The new AC-MXNET-1G-DANTE-EV2/DV2 products use tagged traffic to allow
for MXnet video/audio streams as well as a Dante audio stream all from a single RJ-45 port. To get a stable system there
are configurations to tag the Dante traffic correctly and allow it to travel
across a switch or multiple switches. The Dante interface is set to DHCP by default, and has a default VLAN ID of 99.
In our example we will be using the AC-MXNET-1G-SW24 to
carry the MXnet AVoIP traffic as well as the Dante traffic.
In this system we will use VLAN 100 for MXnet and keep the default VLAN ID, VLAN 99, for Dante. The following steps will configure a network switch to allow for Dante and MXnet traffic to traverse the network, while also configuring a DHCP server on the network switch.
CAUTION: The MXnet interface and Dante interface share the same MAC address. Therefore, they cannot exist on the same IP subnet, or abnormal behavior may occur.
Pre-requisites
- SSH/Telnet/Serial client such as PuTTY or Tera Term.
Link to download PuTTY: https://www.putty.org/
- Procedure for connecting to the switch via SSH, Telnet, or the console port as the following procedure will require this knowledge.
The procedure(s) to connect to the switch via SSH, Telnet, or the console port can be found in the Basic Operation Configuration Guide.
Link to the Basic Operation
Configuration Guide: https://support.avproedge.com/portal/en/kb/articles/how-to-mxnet-switch-basic-operation-and-vlan-configuration
- Dante Controller application
Link to download Dante Controller: https://my.audinate.com/support/downloads/dante-controller
Procedure
***This procedure does not apply to the AC-MXNET-SW10
1.Navigate to the Control Panel on a Windows PC. Underneath the Network and Internet
heading, select the View network status and tasks option.
2. Click on Change adapter settings in the left
panel of the window.
3.
In the Network Connections window, double click on the Ethernet port
that will be used to access the switch or Wi-Fi. In the example below, Ethernet 2
was the port connected to the switch.
4. At the bottom of the Ethernet status menu that appears, click on the Properties button.
5. Under the “This connection uses the following items:” list heading, double click on Internet Protocol Version 4 (TCP/IPv4).
6.
Click on the Use the following IP address radio button and change the
IP address the PC to an IP address within the subnet of the MXnet switch. The MXnet switch IP address can be found using the Basic Operation
Configuration Guide which will be the default IP address of
192.168.1.238. When finished entering the parameters, click OK.
In
this example, the switch IP address is 192.168.2.110, so the PC IP
address was set to 192.168.2.2 with a /24 subnet.
MXnet Dante Switch Configurations
1. Connect to the switch via SSH, Telnet, or the console cable and
log in using the MXNet switch's username and password. Per the Basic Operation
Configuration Guide the default credentials are admin/admin. Screenshots
below represent a connection to the switch through Telnet.
2.On the switch, create VLAN 99 and set the name of VLAN 99 to "dante".
```
config
vlan 99
name dante
```
Expected return from the above command:
3. Create
VLAN 100 and set the name of VLAN 100 to "
mxnet".
```
vlan 100
name mxnet
exit
```
4. Enable IGMP Snooping and Multicast unknown-group drop.
```
no ip igmp snooping
multicast unknown-group drop
ip igmp snooping
```
5. Configure IGMP Snooping attributes for VLAN 100
```
ip igmp snooping vlan 100
ip igmp snooping vlan 100 limit group 1000
ip igmp snooping vlan 100 immediately-leave
ip igmp snooping vlan 100 l2-general-querier
ip igmp snooping vlan 100 l2-general-querier-version 2
ip igmp snooping vlan 100 mrouter-port interface Port-Channel1
```
6. Configure IGMP Snooping attributes for VLAN 99 (optional, if multicast streams are being used with a Dante network)
```
ip igmp snooping vlan 99
ip igmp snooping vlan 99 limit group 1000
ip igmp snooping vlan 99 immediately-leave
ip igmp snooping vlan 99 l2-general-querier
ip igmp snooping vlan 99 l2-general-querier-version 2
ip igmp snooping vlan 99 mrouter-port interface Port-Channel1
```
7. Configure a DHCP pool for Dante Traffic on VLAN 99 (optional, the default setting for the Dante interface on DANTE-EV2/DV2 products is DHCP. Either a DHCP server can be created on the MXnet switch, an external DHCP server can be connected, or the Dante interface can be configured for a static IP address in MENTOR which is explained in the next section). In the below example, a DHCP server with the "192.168.20.x/24" IP address scheme will be created, with the interface of VLAN 99 being set to the IP address "192.168.20.1/24".
CAUTION: The MXnet interface
and Dante interface share the same MAC address. They cannot
exist on the same IP subnet, or abnormal behavior may occur. Therefore, it is recommended to either statically assign the Dante interface, or set up a DHCP server on the Dante VLAN.
```
interface vlan 99
ip address 192.168.20.1 255.255.255.0
exit
ip dhcp pool Dante
network-address 192.168.20.0 255.255.255.0
lease infinite
default-router 192.168.20.1
exit
service dhcp
'''
7. Save/Write configuration
```
end
write
y
```
8. Convert the switch ports for the AC-MXNET-1G-DANTE-EV2s
and AC-MXNET-1G-DANTE-DV2s to act as trunk ports and allow
these trunk ports to pass VLAN 99 (Dante) and VLAN 100 (MXnet).
Note: When configuring a trunk port for DANTE-EV2/DANTE-DV2 devices, it is important to set the native VLAN to the VLAN MXnet traffic is intended to reside on. In this example, VLAN 100 will be set as the native VLAN, so MXnet traffic is tagged appropriately. If the MXnet traffic is on the default VLAN, VLAN 1, configuring the native VLAN will not be necessary.
When
selecting which ports to configure on the MXNet switch, a range of
ports can be selected or specific ports can be selected. For example, if
the Dante endpoints are connected to switch ports 8 through 12 then we
can use the command interface ethernet 1/0/8-12 to specify that specific
range. If Dante endpoints are connected to switch ports 8, 10, and 12
then we can use the command interface ethernet 1/0/8;10;12 to specify
those specific switch ports to configure.
```
config
interface ethernet 1/0/X-Y or 1/0/X;Y;Z... where X-Y represents a
switch port range and X;Y;Z represents individual switch ports
Ex: interface ethernet 1/0/14-18
switchport mode trunk
switchport trunk allowed vlan 99;100
switchport trunk native vlan 100
end
write
enter “y” when prompted
```
Expected return from the above command:
4. Configure the switch port connected to the PC running Dante Controller,
or the port to which it will be connected, to access VLAN 99.
NOTE: This will also need to be applied to any third party Dante device as well!
```
config
interface ethernet 1/0/X where X represents the switch port the PC with Dante Controller is connected to
Ex: interface ethernet 1/0/13
switchport access vlan 99
end
write
enter “y” when prompted
```
Expected return from the above command:
1. On the front panel of the CBOX, there are two
displays labeled “STATUS MONITOR A” (the one on the left) and “STATUS MONITOR
B” (one on the right) respectively. Press the “PRESS TO SCROLL PAGE” button for STATUS
MONITOR A twice to cycle to the third page. The LAN PORT IP Address and Subnet Mask should be present on STATUS MONITOR B. Here is an example of the default IP Address
and a Subnet Mask:
IP Address Example: 192.168.1.239
Subnet Mask Example: 255.255.0.0
Note the CBOX IP Address and Subnet Mask.
2. Navigate to the Control Panel on a Windows PC
and select the View network status and tasks under the Network and Internet
heading.
3. Click on the Change adapter settings in the left
panel of the window.
4. In the Network Connections window, double click on the Ethernet port
that will be used to access the MXNet switch or Wi-Fi. In the example below, Ethernet 2
was the port connected to the switch.
5. At the bottom of the Ethernet status menu click on the Properties button.
6. Under the “This connection uses the following items:” list heading, double click on Internet Protocol Version 4 (TCP/IPv4)
7. Click on the Use the following IP address radio button and change the
IP address of your PC to an IP address within the subnet of the Cbox using the Cbox's IP Address noted above. When finished entering the parameters, click on OK.
In
this example, the Cbox's IP address is 192.168.1.239, so the PC IP
address was set to 192.168.1.240 with a /16 subnet.
1. Click on the Windows Icon or click in the
Search field again which can be found on the taskbar
2. Type the name of a preferred web browser application (Chrome, Firefox, Edge, etc.) and click on the Web Browser
application
3. Open Mentor by entering the IP Address of the
CBOX noted in the section above titled, "Configure the PC IP Address for Cbox access" step 1 into the web browser search bar and press enter.
4. The Login page will appear after pressing
enter.
Here are the default credentials needed to login:
Username: admin
Password: admin
5. After clicking LOGIN, the SYSTEM UTILITIES page
should populate in the web browser:
6. Navigate to the MXNet tool bar, and click on
CONFIGURE.
7.
Across
the top of the CONFIGURE page, select the SET DANTE IP button to open the Dante Module Network Settings menu.
8. DANTE-EV2/DANTE-DV2 device's Dante interface is set to DHCP by default. To configure a STATIC IP ADDRESS, Under the IP SETTINGS tab, click the SET STATIC IP button. Enter an IP address/subnet that will fit with the created Dante network, and click APPLY. Repeat for all Dante EV2s and DV2s in the 1G ecosystem. Ensure the IP Address for each encoder or decoder is properly represented under the IP ADDRESS column. Press the SAVE CONFIG button when complete.
In the example below, the PC with Dante Controller has an IP Address/Subnet of 192.168.199.100/24. The two Dante EV2s were configured with the IP Addresses of 192.168.199.98/24 for Dante EV2 #1 and 192.168.199.99/24 for Dante EV2 #2.
10. To change the VLAN ID of the Dante Interface, navigate to the VLAN SETTINGS tab. Click on the SET VLAN ID button. Enter the desired VLAN ID into the VLAN ID field as shown below, then click APPLY. When VLAN ID adjustment is complete, click SAVE CONFIG at the top right.
Post-steps
Open the Dante Controller software to check the configuration results. Verify the AC-MXNET-1G-DANTE-EV2s and AC-MXNET-1G-DANTE-DV2s are present and controllable via Dante Controller. In the example below, the two Dante EV2's configured in Mentor are now present and controllable via Dante Controller.